Unable to respond to questions on app


#1

My account has yet to be approved but you sent some questions in the app on Friday July 10, which I have tried to respond to, but the app will not deliver my message (see screenshot). You also rang me on Friday as I was about to go into a meeting, and your representative said they would ring back in an hour. It is now almost a week later and they still have not called, and the app still won’t send my message.
I would like someone to contact me as soon as possible so that these issues can be resolved. It is also very difficult to write long responses to a long series of questions in an app, it would be better to deal with those by e-mail.
Can someone please contact me about all of this.
Thank you!
IMG_2300|281x499


#2

Hi there @RussellJAN

Thank you for letting us know about this - I’ve asked the team to reach out to you via email so we can get your application back on track as soon as possible.

Thank you for your patience with us so far!

Regards,
Obi


#3

Thank you for your original response, however it is one week on and I have still not heard anything from you.


#4

They never reached out, I just got all my messages from the app e-mailed back to me with no further response.

I have now opened an account elsewhere, so please terminate my application with immediate effect.


#5

Thank you for coming back to me on this, @RussellJAN

I’m saddened to hear this and will pass this along to the team, thank you for your interest - myself and my colleagues wish you all the best!

Regards,
Obi