Unable to open app


#1

Hello! I’ve had to wipe/factory reset my phone. I’ve reinstalled tide, and when I open the app I just get the “Do less banking” screen. I’m unable to get any further! I have tried uninstalling and reinstalling the app, and have the same problem. Help!!


#2

Sorry you’re having trouble @bbmason,

If you are restoring the apps linked to your previous device, you’ll just need to delete and re-install the app and go through the account recovery process to regain access to your account.

You can read more here

If you need any further assistance, just let our Member Support team know at hello@tide.co :slight_smile:


#3

Hi Kate,

Thanks for your reply. The account recover process was exactly what I wanted to do. However, My phone was stuck before the first step.

I have resolved the problem though. When I disabled my wifi connection and went over to 4G, I was presented with the correct options to login/signup etc. So, it seems to have been a connectivity issue.

Thanks for your help though!

Ben


#4

Hi there,

I have been and continue to have issues signing in to the app to complete my registration.

Cannot seem to get passed the screen after entering my business email address. I have tried wifi - 4g, uninstalling & re-installing the app etc etc. Wondering if any one has previously encountered this issue?

Attached is the screen shot of the page I am stuck on my HTC M8 one mobile phone.

Many thanks in advance.

Ankur


#5

Sorry you’re having trouble @superstylin,

Could you please contact our Member Support team at hello@tide.co so they can look in to this for you?


#6

Hi my app wont long me in even though I put in my security number plz help