Trying to get my account opened


#1

I am having issues with the app is seems.

I tried to open a account last night and I got in app message from the customer service manager asking for additional information.

Iv provided that and then my app crashed.

I am now stuck with (number 1) on the app badge on my iOS devices. When I open the app nothing new shows.

If I reinstall what will happen…? Will I have to redo the application process again?

I just want to get the account up and running


#2

Hi @hellomick,

I believe our on-boarding team has reached out and that you are discussing this with them via the in-app chat.

Let me know if you have any other questions about Tide, I’m happy to help :slight_smile:

Thanks,
Valentine


#3

Why is it taking so long to get a response back via the app?

This is a massive issue it seems with Tide. The slow response times with customer services


#4

It seems to be taking over 4 hours to get a reply from customer services.


#5

Hi @hellomick,

I’m really sorry for the delay you experienced. We have received a very high number of applications lately. Our number one priority is to provide the best service to our members - rest assured that the team is on it and are working hard to get back to messages as quickly as possible.

I believe the team is in touch to further assist you. Don’t hesitate to let them know if you have any other questions.

Thanks,
Valentine


#6

Thank you for the reply.

Cool name by the way !


#7

I have not had a response in over 24 hours now… this is getting beyond a joke


#8

Hi @hellomick,

The team should have reached out to you again.

Let me know if there’s anything else I can do to help :slight_smile: