Welcome to the community

IMPORTANT: Tide Community is closing - we’re building something better!

Thank you for sharing your feedback, questions and ideas. We very much appreciate your contributions - and now it’s time for something new. To better support you, and to showcase your businesses, we’re developing a member directory.

5th February 2021: This forum is now ‘static’ so it's not possible to add a new topic or comment.
Summer 2021: The forum will close. Read more

Had to update App and now I can’t access account as the updated app won’t take a photo of driving license or password.
Tried e-mailing Tide but just get told to uninstall and do it again, which doesn’t work.
Asked tide to phone me, they haven’t I just get repeated instructions.

Going to open an account with Mettle if can;t sort this quickly

  • created

    Nov '20
  • last reply

    Dec '20
  • 6

    replies

  • 61

    views

  • 6

    users

Thank you for reaching out about this here @Wobbly123

I’ll have a look into this right away and be in touch as soon as I possibly can to help you out.

Regards,
Obi

Received a private reply to say nothing they could do about it. Useless customer service. Now can’t access or use my account.

I have now managed to get passed the ‘recognise passport’ stage of my application, but when I open the app with my passcode, it says “verifying your details, this make take 5 minutes or so”, you can close the app now.
That was two weeks ago, and every time I open it, I still get the same message!!!
Help!!!

[email protected]

I have had the same issue, I have lost my phone and reinstalled the app in my new phone but the app is not scanning my passport.

I have emailed but no reply and i need access to my account, I’m trying to run a Business.

This is terrible service I’ve been locked out of the account for 4 days now

Hello @Neo2020,

We are sorry for the experienced inconvenience.

We have located the case and escalated it to our dedicated team with priority, they will be in touch via the thread you have together as soon as possible.

Regards,
Borislav