Still no response. Please help


#1

It’s now an hour since I first tried to contact Tide and I’ve still had no response. All I want to do is get access to my account after resetting my phone, but the app isn’t letting me do that. Instead it’s just sending me through the new account process. Please, someone, reply.


#2

Hello Kevin,

Thank you for drawing this to our attention.

Please do accept my sincere apologies for the delay in response - we’re currently experiencing a higher volume of requests than usual.

I’ve traced your correspondence thread and would love to help you further. Please bear in mind that= once you uninstall and reinstall the Tide app or try to open it on another device, you’ll have to go through Account Recovery process. Once you’re at that point, make sure you use your ID and the exact same email address as initially used when setting up your account otherwise you will be prompted to set up a new account.

Hope this helps and I look forward to helping you further! :slight_smile:


#3

Then why not post a sticky on this forum, and send an auto response so you can manage expectations? I even got to the point where I tweeted your CEO about I, which maybe proves that only when the boss finds out does anyone pay attention. I’ve got access because it was down to an email address. But 2.5 hours? Seriously?


#4

Hi again! We always strive to deliver fast and effective solutions for all our members and we understand that urgent cases need emergency action. That’s why we are actively upscaling our number of Member Support Agents to meet increasing demand from our member base, so we’re confident that we can offer you a great standard of service moving forward.

We urge our members to try and keep communications on a single channel where possible, so we can assist you to the best of our abilities, avoid any delays, as well as confusion.

I’m grateful for your understanding and cooperation. You can always mention my name should you require any assistance - I’m always here to help! :blush: