Welcome to the community

IMPORTANT: Tide Community is closing - we’re building something better!

Thank you for sharing your feedback, questions and ideas. We very much appreciate your contributions - and now it’s time for something new. To better support you, and to showcase your businesses, we’re developing a member directory.

5th February 2021: This forum is now ‘static’ so it's not possible to add a new topic or comment.
Summer 2021: The forum will close. Read more

Same here - cant get in to my account - had to get link to log in here.

Same here connection problems at first. Just received an email from tide confirming outage.

Very annoying as I had banking to do today.

This is what I done, deleted the app and downloaded it again, it then said it could take 2 hours to verify.
was very buggy in loading and sending verification codes.

had to do everything lots of times wouldn’t recognise my mobile number as a number.

It told me it was unable to verify so you got further than me lol

working now, received the following email explanation

You can now access the app as normal

You may have had trouble accessing our app earlier due to a problem experienced by our technology provider. This has now been resolved, and we have been notified they are no longer experiencing availability issues.

You should now be able to access the Tide app, as well as any other apps that were affected.

We apologise for any inconvenience caused. If you continue to experience this problem, please reach out to our team.

Regards,
Team Tide

Still having problems, Un-installed app then re-installed, completed security after numerous attampts.
Now get message additional checks required. In meantime Tide set me new re-activation code but cant enter it anywhere because still get additionalchecks required.
Kevin

What ever next. An app you can’t use on an online only bank. But it’s not Tides fault.

What do Tide actually do themselves. You don’t provide the cards, you don’t have a banking licence, you don’t hold any funds. You don’t issue BBL, you don’t respond to customers issues for days.

As much as I can see you just take a percentage of transaction for doing nothing

8 days later

I cannot make the App work on my iPhone.
I am just getting a ghosted version of the Security Code entry screen, and it will not let me do anything.
It has been like this for at least 1 day now.

Is it broken?
How soon will it be mended?

John

Solved.

I tried re-starting my 'phone, and that cured it.

John

Hi there @CfL

I’m glad to hear that such a simple step was able to sort out the issue for you - if you do encounter any kind of technical error with the app, please don’t hesitate to contact the team at [email protected], so they can assist you.

Regards,
Obi

10 days later
3 months later

closed Dec 14, '20

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.