Welcome to the community

IMPORTANT: Tide Community is closing - we’re building something better!

Thank you for sharing your feedback, questions and ideas. We very much appreciate your contributions - and now it’s time for something new. To better support you, and to showcase your businesses, we’re developing a member directory.

5th February 2021: This forum is now ‘static’ so it's not possible to add a new topic or comment.
Summer 2021: The forum will close. Read more

I like many others am having trouble with your app that clearly doesn’t work. I am stuck at photograph ID step. Been on to your help desk twice. re-installed the app 3 times - although the support guy couldn’t explain what difference that would make as the app wasn’t being updated. Tried on my wife’s iPhone - didn’t work; tried on wifi - didn’t work; tried via phone network - didn’t work; left phone staring at passport for 10 minutes - didn’t work; left phone staring at drivers license for 10 minutes - didn’t work; tried different coloured backgrounds - didn’t work; had the phone lying on a table with the ID on the floor underneath - didn’t work; tried phone at different distances between phone and ID - didn’t work. Tried phoning you this morning - didn’t work, you don’t work Saturdays. YOUR APP DOESN’T WORK - GIVEN UP.

11 days later

Hello @UnableToTakePhoto

Thank you for contacting us and sorry for the delay in getting back to you here.

Could you please confirmed if you have been in touch with our on-boarding specialists team over the phone?

Looking forward to hearing from you.