Can't open app


#1

App just shows blue screen with logo + spinning wheel - never loads past this screen.

Have tried:

  • deleting + reinstalling app
  • restarting device
  • using wifi + cellular data
  • no VPN

Anything else to help?
Have emailed you but no response.


#2

Hello Robert,

Thank you so much for getting in touch and letting us know about this!

I can confirm that this issue has been escalated to our Production Support team with all the details required plus the ones that you’ve so kindly provided. We will actively monitor your case and you may rest assured that as soon as an outcome is received, you will be notified as quickly as possible via e-mail or here.

Thank you for your patience and cooperation!


#3

Ive got the same issue, tried same solutions to no effect, contacted tide via hello@tide.co and got no response…


#4

We also have the same issue and tried the same solutions with no luck


#5

I have also have started with this problem today with no luck getting it going again. :frowning:


#6

And over a day later, the problem still persists and still unable to access the account


#7

I’m also unable to open the app with the same issues described above. Have tried every method recommended to fix this but no solution. Have also emailed Tide.


#8

I’m also experiencing this problem. I’ve tried emailing them, tweeting them and responding to boards about it on here but no response.

What’s more worrying is that many people are having this issue but Tide haven’t issued a public statement to explain the situation or when it will be resolved.

Something major has happened and they’re trying to control the PR, but it’s not working.


#9

I find the lack of telephone customer support quite concerning, but just take it for granted when everything’s running smoothly (most of the time)


#10

Not being able to access your company’s money for three days straight is a real issue and not having any official statement about this problem that many seem to experience is quite concerning.


#11

Hi, @pablopost, @hamdicraft, @philmet, @danny.h.935 and @WHTM

Thank you for reaching out and I sincerely apologise for the inconvenience this has caused.

Our tech team are looking at this as a high priority and as soon as I have further information from them I will pass this onto yourselves.

If you do have questions or queries in the meantime, please email your full name and business name to hello@tide.co and an agent will be happy to assist.

Apologies once again.

Thanks,
Nick


#12

Yes the lack of support outside the app and the fact that without the app you cant access your account do rather make you doubt that Tide is the right account to run a business with. Unless I get access soon it’s going to cause serious problems. And a pretty bland and uninformative “we’re sorry … “ message once a day doesn’t really cut it


#13

Can someone provide an update + ETA on the fix for this iOS issue?
We’re onto Day 6 with no access to bank accounts - the suggestion to use an android device isn’t very helpful unless you’re going to courier out an android handsets to those affected.


#14

Hi, I am also unable to log in and completely agree that not being able to use my laptop to log in (as the app is still requiered to log in on a website)
It is very bad experience so far from this as only been unsing it for a month and already facing issues like this is unacceptable.


#15

Same issue here, Blue screen with a spinner on iphone 11 pro with iOS 13. I can not login and not make any payments. I started to think that migrating to Tide was a mistake.


#16

Our team is doing the best it can to resolve this issue as soon as possible.

We will reach out accordingly today with further information on the matter.

Thank you for your patience and understanding!

Kind wishes,

David


#17

re-instate the previous working app, until you find your mistakes


#18

I managed to get back into the app by backing my iphone up, wiping the handset and restoring a backup.

All was well. Until I went out of the app and I was locked out once more.

Tide should seriously be looking at a web interface with 2FA/Authenticator or other details so we have a backup if theres another chance this may ever happen again.

I cant say im not unhappy - I have been looking around at other banks for my business.


#19

Hi, @pablopost , @hamdicraft @philmet @danny.h.935 @WHTM @wellie51 @thebunce and @myakici

We’re glad to confirm that we’ve now found a resolution to the problem you’ve been facing with regaining access to your account. This has now been resolved in the backend. If you could kindly delete and reinstall the app, this will allow you to regain access to your account.

Should you have any further questions regarding your account, please do contact us at hello@tide.co or through the in-app chat - we’ll be more than glad to help!