Brand new phone, app won't open after reinstalling


#1

Hi there, I’m not able to access my Tide account because the app won’t open any more.

I’ve got a new Oneplus 7 and reinstalled the app along with all my others, but it sticks on the blue “Smart business banking” / logo screen, seemingly forever.

I’ve tried clearing the data, cache & reinstalling from the Play store. Every other app I use has reinstalled fine, and the phone seems to be working apart from this issue.

How can I use Tide again on my new phone?


#2

I just tried installing it on my wife’s phone (a Oneplus 3T). Same thing - just hangs there on the title screen.

I’ve still got access to my old phone where it works, but not for long.


#3

Ah - that failure clued me in.

We run Pi-hole at home which is a network-wide ad blocker, and that stops Tide accessing a marketing service.

(devs: it tries to resolve logx.optimizely.com - on my home network it retries forever, presumably because pi-hole resolves it to 0.0.0.0).

To work around the problem, I cleared the app’s data, switched over to 4G, and the app started normally.

Optimizely doesn’t seem crucial to Tide’s operation, particularly for paying customers - so I’d say this doesn’t seem like robust enough behaviour for a banking app (but I would say that :smile:).