App not responding just keeps spinning


#1

I am getting really frustrated that there is no simple customer service dedicated team, everthing is based on email that is not speedy it takes people hours to respond.

I need to get into my business account but Its not allowing me to. The app on my phone just keeps spinning and doesn’t go past the log in page. I have restarted my phone, uninstalled the app made sure no VPN was activated but still not working. I am on the verge of moving banks because this is shocking.


#2

Hi @JayDaniels ,

We have updated our dedicated incident page :warning: Logging issues - Monday 24th June.

The outage suffered by the global network connectivity provider, Cloudflare, is now fully fixed and Tide members should be able to log in to their Tide accounts as normal.

Please rest assured that our Member Support team who is dedicated to supporting our members is available 7 days a week via the in-app chat and hello@tide.co - I’m afraid that due to the outage at our third-party provider, the in-app chat was inaccessible for a few hours but it’s now fully accessible.

If you’re going through account recovery, please make sure you’re using the same email address you’ve used to open your Tide account.
If you’re still experiencing issues, could you please reach out to our Member Support team at hello@tide.co?

Thanks,
Valentine


#3

I need to speak to someone or else I am taking my business elsewhere. I have sent emails, written lots of things on here called the lost or stolen help line. I am getting fed up at the moment.


#4

Hi @JayDaniels,

I know you are talking with Atanas from our Member Support team and that he’s further assisting you with this.

Don’t hesitate to get back to him if you have any questions.

Thanks,
Valentine