Account opening stuck / No email replies anymore


#1

Hello!

I am the directory or A******** P****** H**** Limited in Merseyside (Liverpool).
As our company is a subsidiary of another company, we got asked to provide notarized and translated documents, which we have turned in about one week ago. Since then, we did not get any feedback anymore, despite sending an email to hello@tide.co twice.

Could anyone please have a look at this?

Kind regards,
Torsten


Again: For security reasons the Tide app is unable to run on this device
#2

Hi Torsten!

I can see that our On-boarding team and an agent from the Member Support team has been in touch with you regarding your application.

If you need any further questions or queries to be answered, please feel free to message our agents, they will be glad to help!

Thanks
Nick


#3

Hi Nick!
When did that contact possibly happen?
Within the last two weeks?
If the representative tried to contact us via the app, the problem may be that we are suffering from “The app cannot run due to security reasons” problem.
So it might be worth to try again to reach out to us via email.
Regards,
Torsten


#4

Hi again!

We had to re-install the application and now cannot login; possibly because our account is somewhere half-way. So please have someone come back to us via email. We will not receive chat messages in the app.

We have supplied all documentation that has been asked for and would appreciate some feedback on where we stand. I don’t think it will be a good use of everybody’s time to start the whole process all over, will it?

Regards,
Torsten


#5

No comment after two full days.
What’s going on?


#6

No comment after 4 days.
Why are you ignoring me now?