Accessing your account on another phone


So I just got a new replacement phone. I still have access to the old one and the Tide app.

But after completing photo verification I will still have to wait for snail mail verification?

I’m away from the country for 6 weeks. What should I do?


Hi Harry,

Sorry to hear you are having trouble accessing your account. Could you please reach out to one of our Founder Member managers through the in-app chat? We would be happy to help!


Is it possible (as we are a partnership) to have the Application on two mobile telephones so both partners can access the system? Also is it possible to issue two cards, one for each partner?
many thanks.


Hi @RAHM, thanks for your question. Our Product Development team are currently working towards introducing multi-user access. However, at this stage this feature is unavailable as our app only has single-user capabilities. You will be able to add both partners & provide them with cards when this feature is released on the app. Thanks for your patience.


Hi… this would be an amazing feature and from what I can see really needed… Please please get your people to add these features! :slight_smile: I’m sure members on here could help with the software design!


Well we did it… we are now TIDE users!


Hi @RAHM, welcome to Tide and our Community! Glad to have you on-board. We are aware of the demand for multi-user access and I can assure you we’re making this a priority.


Hi, has Tide got anywhere with the above please? I want to set up an account with my business partner and we will both need access to the app from different devices. Thanks.


Ive have had a tide account for several weeks now but still unable to use it. Set it up on a phone but then broke the screen. Tried the app on another phone and it wont allow me to re-register - just keeps trying to open a new account then says I cant. Got screen repaired on my phone but now have to reload the app - and the app still wont allow me to re-register. Tried it on a third phone and again it still wont allow me to re-register and when I retried it the app simply refused to open. Desperately need to pay in some money but its getting to the point where I suspect it might just be simpler to set a different bank account up.


Hi, really sorry to hear about this. Could you please reach out to us via Our Help team would be more than happy to assist you through this process.


Hi Victoria - thank you I will email them. Is that the full email address


Yes, that’s the full email


I have a new phone - when I get to the stage where I need to rescan my ID i get “invalid multipart request” and can not go any further.

There MUST be a simpler way to change your phone and not lose business banking!

Any ideas on how i might proceed to get back to my account?? Changing phones these days is common place.


Eventually got the id to be accepted and was pleased to see that the new security code was sent by text message so no need to wait for post! Great.


Hi @customerinteract, pleased to hear that this was sorted in the end. However, if in doubt, do get in touch with our Help team via or via the in-app chat. They’re always on hand to assist :slight_smile:


Are you still able to use the old phone too? Don’t want to try in case it mixes things up…
It’s great that you can now change phones immediately though


Hi @customerinteract, thanks for your feedback. You should be able to access your account on your old phone as well.


is this sorted now as I have tried to login on an iPhone and it makes me register again - not valiate my info but register!

have it setup on android but need to login on iPhone so I can link my account to xero

again pretty crappy as android wont let you do this !


Sorry you’re having trouble @lottie,

If you’re being prompted to sign up, rather than being pushed through account recovery, the email address you’re entering is not linked to an active Tide account.
Are you still logged in on your android device? If so, you can find the email address linked to your account by selecting ‘More’, then ‘About me’.

If you’ve any trouble just email, we’d be happy to assist :slight_smile:


Have been experiencing troubles with the reactivation of the app after a new mobile phone had to be used.
The logo appears and nothing else.

Anybody from the support team to advice?